Powered by Invision Power Board
Доброго времени суток, уважаемые новички форума и те, кто не так давно зарегистрировал форум на нашем сервисе. Обращаем Ваше внимание на то, что данный форум - своеобразная база знаний, на которой хранятся ответы на все Ваши сформировавшиеся (также как и не сформировавшиеся) вопросы по работе Вашего форума. Администрацией сервиса было принято решение написать документацию по использованию поиска по форуму технической поддержки. Мы понимаем, что конечно лучше, когда именно Вам лично дают качественный ответ, но ответы на большинство вопросов уже даны - достаточно правильно спросить поисковик, и он найдёт Вам то, что Вы ищите.
  1. На этом форуме осуществляется техническая поддержка только и только форумов IP.Board Сервиса IPB.SU.
  2. Заполните в Профиле поле: "Адрес Вашего форума" - это упростит работу Aдминистрации при решении Bаших проблем.
С уважением,
Администрация Сервиса IPB.SU!


Страницы: (18) « Первая ... 15 16 [17] 18   ( Перейти к первому непрочитанному сообщению ) Reply to this topicStart new topic

> Сообщения об ошибках
Ларочка
Quote Post

Новичок
Group Icon


Сообщений: 38

Активность: Member Offline


Ответить Автору

Репутация: 2


Здравствуйте!

Возникает такая проблема - при попытке пользователей установить часовой пояс в профиле вылетает сообщение:
Сообщение Форума
Обнаружена ошибка. Если Вам неизвестны причины ошибки, попробуйте обратиться к разделам помощи.

Обнаружена ошибка:

Мы рассматриваем это действие, как возможная попытка взлома. Данное действие уже записано в логах Администратора форума и он будет уведомлён по e-mail

,.....
Пользователи пугаются unsure.gif

Пожалуйста, подскажите как исправить или хотя бы поставить по умолчанию московское время
PMEmail Poster
Top
Ларочка
Quote Post

Новичок
Group Icon


Сообщений: 38

Активность: Member Offline


Ответить Автору

Репутация: 2


Здравствуйте!

Возникает такая проблема - при попытке пользователей установить часовой пояс в профиле вылетает сообщение:
Сообщение Форума
Обнаружена ошибка. Если Вам неизвестны причины ошибки, попробуйте обратиться к разделам помощи.

Обнаружена ошибка:

Мы рассматриваем это действие, как возможная попытка взлома. Данное действие уже записано в логах Администратора форума и он будет уведомлён по e-mail

,.....
Пользователи пугаются unsure.gif

Пожалуйста, подскажите как исправить или хотя бы поставить по умолчанию московское время
PMEmail Poster
Top
gagarin
Quote Post

undefined is not a function
Group Icon


Сообщений: 68

Активность: Member Offline


Ответить Автору

Репутация: 4


Цитата (gagarin @ Окт 26 2018, 15:24)
Цитата (admin @ Окт 24 2018, 15:20)
gagarin, проблема более не должна возникать. Просьба сообщить, если подобное будет замечено вновь.

Вместо 404.shtml действительно теперь показывается какая-то страницы, видел. Кэшируется ли этот редирект на /404.shtml браузером - пока не проверял (как раз в этом и есть основная проблема). Будем следить, спасибо за фикс!

Редирект всё ещё кэшируется. Форум воскрес, а браузер идёт по редиректу на 404.shtml из кэша.
PMEmail Poster
Top
Ларочка
Quote Post

Новичок
Group Icon


Сообщений: 38

Активность: Member Offline


Ответить Автору

Репутация: 2


Здравствуйте
Вышеуказанный баг был, оказывается, поставленный мною по моей оплошности. blink.gif Я пыталась убрать из профиля полностью окошечко для изменения состояния формы быстрого ответа. Я поставила ремарки И после этого система на любые изменения в профиле настроек форума начала ругаться на взлом.
Простите за панику!
Сняла ремарки и всё восстановилось.
Вопрос снимается.

Всем добра!
PMEmail Poster
Top
Ларочка
Quote Post

Новичок
Group Icon


Сообщений: 38

Активность: Member Offline


Ответить Автору

Репутация: 2


Здравствуйте, уважаемые.

Возникла проблема с почтой форума - ее нет. То есь уведомления ни о новых сообщениях, ни о новых регистрациях, ни жалобы модерации не приходят. Пользователям тоже не приходит.
Я пробовала сменить ящики, но конечно это не дало результат. В кодах почты ничего не менялось. Единственное действие было в дни примерного пропалания доставки почты - я удалила логи ботов. Не знаю, может ли это каким-то образом быть связано. И да, раньше форум тормозил конкретно, а теперь отлично загрудается. Но почта отвалилась... Если тормоза связаны с почтой, то лучше скорость оставить. Без почты мы справимся.
Личные сообщения работают.

Полскажите, пожалуйста, в каком месте смотреть и что исправлять. Или это не от форума зависит.

Спасибо.
PMEmail Poster
Top
admin
Quote Post

Разработчик
Group Icon


Сообщений: 5 386

Активность: Member Offline


Ответить Автору

Репутация: 176


Ларочка, это общая проблема сервиса. Разбираемся.


--------------------
Ответы на очень многие вопросы уже много раз давались на форуме. Пожалуйста, перед созданием темы с вопросом пользуйтесь поиском.

user posted image
PM
Top
Arwen
Quote Post

Новичок
Group Icon


Сообщений: 4

Активность: Member Offline


Ответить Автору

Репутация: нет


Здравствуйте!

Скажите, пожалуйста, как можно исправить время на форуме, оно отстает на 18 минут?! Поиск не выдал ответа на мой вопрос.
PMEmail Poster
Top
admin
Quote Post

Разработчик
Group Icon


Сообщений: 5 386

Активность: Member Offline


Ответить Автору

Репутация: 176


Arwen, исправили, теперь серверное время корректное.

В случае чего корректировать время можно в АдминЦентр -> Системные настройки -> Формат даты и времени -> Коррекция часов сервера (в минутах)


--------------------
Ответы на очень многие вопросы уже много раз давались на форуме. Пожалуйста, перед созданием темы с вопросом пользуйтесь поиском.

user posted image
PM
Top
gagarin
Quote Post

undefined is not a function
Group Icon


Сообщений: 68

Активность: Member Offline


Ответить Автору

Репутация: 4


admin, прошло 2 года, а проблема с /404.shtml всё ещё осталась, хотя вы что-то и предпринимали для её исправления.

Попытаюсь ещё раз изложить суть проблемы (могу ошибаться в деталях)

Как было раньше:
1. Скрипт форума тормозит (это не ок, но допустим, так бывает)
2. Пользователь заходит на страницу форума (пусть это будет главная /index.php), веб-сервер не дожидается ответа от скрипта форума, редиректит пользователя на /404.shtml
3. На /404.shtml отвечает тоже скрипт форума (который тормозит) и редиректит на /404.shtml/404.shtml
4. Шаг 3 повторяется, пока браузер не скажет "слишком много редиректов".
5. Скрипт форума перестаёт тормозить.
6. Пользователь заходит на /index.php. Браузер пользователя помнит, что его перенаправляли отсюда с кодом 301 (перемещено навсегда) и даже не пытается сделать запрос к /index.php а сам идёт на /404.shtml и идёт по цепочке редиректов из шагов 3-4.

Сейчас (после ваших попыток решить проблему) и из прошлой последовательности исчезли шаги 3-4, теперь так:
1. Скрипт форума тормозит (это не ок, но допустим, так бывает)
2. Пользователь заходит на страницу форума (пусть это будет главная /index.php), веб-сервер не дожидается ответа от скрипта форума, редиректит пользователя на /404.shtml
3. На /404.shtml отвечает веб сервер, показывает красивую (условно) страничку.
4. Скрипт форума перестаёт тормозить.
5. Пользователь заходит на /index.php. Браузер пользователя помнит, что его перенаправляли отсюда с кодом 301, перемещено
навсегда и даже не пытается сделать запрос к /index.php а сам идёт на /404.shtml и показывает пользователю красивую (условно) страницу.

То есть пользователь после того, как зашёл на тормозящий (в какой-то момент) /index.php продолжает видеть страницу с ошибкой ещё месяц (когда форум уже не тормозит) и в этом-то и заключалась проблема тогда и заключается сейчас. Бесконечные редиректы были дополнительной, но не критичной проблемой.

Есть два варианта, как исправить:
1) делать редирект на /404.shtml с кодом 307, а не 301
2) выставить в ответе с редиректом правильные заголовки Cache-Control

И то и другое решение вроде как должно элементарно реализовываться.

Сделайте пожалуйста, или хотя бы объясните, почему этого делать принципиально нельзя и не следует.

Я уже устал отвечать на вопросы пользователей так:
- у меня форум 404 отдаёт
- очисти кэш браузера

Это ненормальный сценарий пользования форумом.
PMEmail Poster
Top
gagarin
Quote Post

undefined is not a function
Group Icon


Сообщений: 68

Активность: Member Offline


Ответить Автору

Репутация: 4


Цитата (admin @ Янв 29 2019, 15:33)
Arwen, исправили, теперь серверное время корректное.

В случае чего корректировать время можно в АдминЦентр -> Системные настройки -> Формат даты и времени -> Коррекция часов сервера (в минутах)

Кажется вы когда-то обещали, что сделаете чтобы этого не происходилоsmile.gif

http://ipboard.net/index.php?showtopic=411...indpost&p=59741
PMEmail Poster
Top
gagarin
Quote Post

undefined is not a function
Group Icon


Сообщений: 68

Активность: Member Offline


Ответить Автору

Репутация: 4


Цитата (gagarin @ Мар 7 2019, 23:31)
Скрипт форума тормозит (это не ок, но допустим, так бывает)

Кстати, о тормозах. У меня возникло ощущение, что когда я редактирую шаблоны в админке, тормозить начинают чуть ли не все форумы сервиса. 100% уверенности нет, но неоднократно замечал корреляцию.
PMEmail Poster
Top
admin
Quote Post

Разработчик
Group Icon


Сообщений: 5 386

Активность: Member Offline


Ответить Автору

Репутация: 176


gagarin, сейчас редирект прописан таким образом:
Код
header("HTTP/1.1 307 Temporary Redirect");


Я с проблемой давно не сталкивался, но, скорее всего, из-за своей малой активности. На выходных посмотрю, в чём ещё может быть проблема.

Цитата
Кстати, о тормозах. У меня возникло ощущение, что когда я редактирую шаблоны в админке, тормозить начинают чуть ли не все форумы сервиса. 100% уверенности нет, но неоднократно замечал корреляцию.

Не вижу причин, по которым это может быть как-то связано.


--------------------
Ответы на очень многие вопросы уже много раз давались на форуме. Пожалуйста, перед созданием темы с вопросом пользуйтесь поиском.

user posted image
PM
Top
gagarin
Quote Post

undefined is not a function
Group Icon


Сообщений: 68

Активность: Member Offline


Ответить Автору

Репутация: 4


Цитата (gagarin @ Ноя 21 2018, 01:08)
Редирект всё ещё кэшируется. Форум воскрес, а браузер идёт по редиректу на 404.shtml из кэша.

Когда я это писал, я натыкался сам и посмотрел запросы в браузере.

Когда писал вчера, мне жаловались пользователи (присылали видео с проблемой). В конкретно этом случае я не полностью уверен, что всё происходит именно так, но очень сильно похожи симптомы: пользователь кликает по ссылке на форуме, ему моментально и повторяемо показывается /404.shtml. По другим ссылкам всё ок, у меня тоже всё ок.

Я бы перепроверил сам, но что-то не очень легко это воспроизводится.
PMEmail Poster
Top
roman911
Quote Post

Суровый
Group Icon


Сообщений: 81

Активность: Member Offline


Ответить Автору

Репутация: 1


Ошибка описанная пользователем выше не исчезает. Сейчас я не могу попасть ни на свой форум ни в админку. Форум или выдает 404 ошибку, или загружает просто пустой фон главной страницы и всё.
Что скажете? Что мне делать???
PMEmail Poster
Top
roman911
Quote Post

Суровый
Group Icon


Сообщений: 81

Активность: Member Offline


Ответить Автору

Репутация: 1


Цитата (roman911 @ Мар 16 2019, 14:33)
Ошибка описанная пользователем выше не исчезает. Сейчас я не могу попасть ни на свой форум ни в админку. Форум или выдает 404 ошибку, или загружает просто пустой фон главной страницы и всё.
Что скажете? Что мне делать???

Изменил скин и форум заработал
PMEmail Poster
Top
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:

Topic Options Страницы: (18) « Первая ... 15 16 [17] 18  Reply to this topicStart new topic


 


Текстовая версия